Go Back   i-Club > Engine and Drivetrain Tech Forums > Engine/Power - EJ20T (pre-2006 WRX and JDM)
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read ExperienceUsed CarsGarageVendor Directory

Welcome to I-Club!
Welcome to I-Club,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 08-27-2005, 06:03 PM   #1
Registered User
Personal Sales Rating: (3)
 
WREXNFX's Avatar
 
Join Date: May 2005
Location: Milpitas
Drives : 05 WRX Wagon and 08 Civic Si
Posts: 848
Points: 7,458, Level: 57
Points: 7,458, Level: 57 Points: 7,458, Level: 57 Points: 7,458, Level: 57
Level up: 54%, 92 to go!
Level up: 54% Level up: 54% Level up: 54%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
I smell oil burning but dont see a leak

Today I installed my coilovers then went out for a test drive came back and the car was idling in the garage and i could smell some oil burning just a little bit not real strong, I looked all around the engine compartment and under the car nothing dripping on the ground and no smoke from the exhaust area but still the smell of burning oil. I reved it up a bunch of times and it smokes a bit out the exhaust. note: I have catless downpipe and catback exhaust only.
now i never smelt oil till today but I know installing new struts can not cause a engine oil leak the smell is engine oil not gear oil > gear oil stinks worse when it burns.
could it be blowby??? i heard subys get alot of oil blowby under decel and normal operation?
anyone got any suggestions? I will pull the belly pan and makesure my oil filter isnt leaking <didnt find any leaks under the belly pan > monday when i get to work and rack it up and look at the underside fully.
its only got 3000 miles on it the turbo seals better not be going already or anything internal.

Last edited by WREXNFX; 08-27-2005 at 09:03 PM.
Offline
 
Reply With Quote
Old 08-27-2005, 07:57 PM   #2
VIP Member
Personal Sales Rating: (8)
 
tigsterz's Avatar
 
Join Date: Apr 2005
Location: SJ bayarea
Drives : 05' WRX STi
Posts: 481
Points: 7,750, Level: 58
Points: 7,750, Level: 58 Points: 7,750, Level: 58 Points: 7,750, Level: 58
Level up: 50%, 200 to go!
Level up: 50% Level up: 50% Level up: 50%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
did u use wd-40? its just prob burning off.
Offline
 
Reply With Quote
Old 08-27-2005, 08:17 PM   #3
Registered User
Personal Sales Rating: (3)
 
WREXNFX's Avatar
 
Join Date: May 2005
Location: Milpitas
Drives : 05 WRX Wagon and 08 Civic Si
Posts: 848
Points: 7,458, Level: 57
Points: 7,458, Level: 57 Points: 7,458, Level: 57 Points: 7,458, Level: 57
Level up: 54%, 92 to go!
Level up: 54% Level up: 54% Level up: 54%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
no thats not it i know what wd 40 smells like burning cus i smelt that after installing my downpipe this is engine oil plus its a 05 car nothing is stuck or rusted so it comes apart without wd40
Offline
 
Reply With Quote
Old 08-28-2005, 06:30 PM   #4
Registered User
Personal Sales Rating: (3)
 
WREXNFX's Avatar
 
Join Date: May 2005
Location: Milpitas
Drives : 05 WRX Wagon and 08 Civic Si
Posts: 848
Points: 7,458, Level: 57
Points: 7,458, Level: 57 Points: 7,458, Level: 57 Points: 7,458, Level: 57
Level up: 54%, 92 to go!
Level up: 54% Level up: 54% Level up: 54%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
it went away the smell is gone now and no more smoke out the exhaust either thats was weird. oh well im happy
Offline
 
Reply With Quote
Old 08-28-2005, 10:59 PM   #5
Registered User
Personal Sales Rating: (0)
 
Tomasu's Avatar
 
Join Date: Apr 2005
Location: SoCal
Drives : 05 WRX
Posts: 41
Points: 5,581, Level: 48
Points: 5,581, Level: 48 Points: 5,581, Level: 48 Points: 5,581, Level: 48
Level up: 16%, 169 to go!
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
i have 5800 miles on my 05 so far, and ever since i got it it stinks like burning oil constantly, without dripping at all.. never smokes, never leaks, just stinks like a ****. Constantly people are telling me something is wrong wiht my car cause it smells like burning oil, and my friends cant stand driving behind me cause of it too. I never got much feedback when i tried to figure it out, so i said **** it, car drives the same, oil level is fine. If anything breaks it'll be covered under warranty.

Dont know if your case is the same, but keep us posted if u figure out what it is.
Offline
 
Reply With Quote
Old 08-30-2005, 04:35 PM   #6
Registered User
Personal Sales Rating: (0)
 
Tomasu's Avatar
 
Join Date: Apr 2005
Location: SoCal
Drives : 05 WRX
Posts: 41
Points: 5,581, Level: 48
Points: 5,581, Level: 48 Points: 5,581, Level: 48 Points: 5,581, Level: 48
Level up: 16%, 169 to go!
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Quote:
Originally Posted by Tomasu
i have 5800 miles on my 05 so far, and ever since i got it it stinks like burning oil constantly, without dripping at all.. never smokes, never leaks, just stinks like a ****. Constantly people are telling me something is wrong wiht my car cause it smells like burning oil, and my friends cant stand driving behind me cause of it too. I never got much feedback when i tried to figure it out, so i said **** it, car drives the same, oil level is fine. If anything breaks it'll be covered under warranty.

Dont know if your case is the same, but keep us posted if u figure out what it is.


Little update from this post... My car just started smoking lightly from underneath after long drives... i think i might be leaking tranny oil onto the exhaust, not sure, im gunna have to take it to the dealership once i get a chance. Car still feels normal though.
Offline
 
Reply With Quote
Old 09-06-2005, 03:20 PM   #7
Registered User
Personal Sales Rating: (0)
 
Tomasu's Avatar
 
Join Date: Apr 2005
Location: SoCal
Drives : 05 WRX
Posts: 41
Points: 5,581, Level: 48
Points: 5,581, Level: 48 Points: 5,581, Level: 48 Points: 5,581, Level: 48
Level up: 16%, 169 to go!
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
OK theres OIL everywhere under on my exhaust pipes, burning smell is really bad... i just called the dealership and im taking it in tomorrow... they better not give me a buncha **** and try to void my warranty for driving my car normal...

ANYBODY ENCOUNTER THIS BEFORE!??!?!?!?!?!?!?!?!

Checked my oil level and its super low only after 3000 miles. Total of 6344 miles and the ****s leaking/burning oil, wtf!?! And i baby the car too. Heres some pics:














Offline
 
Reply With Quote
Old 09-06-2005, 04:14 PM   #8
Registered User
Personal Sales Rating: (1)
 
MVWRX's Avatar
 
Join Date: Aug 2004
Location: UCIrvine
Drives : '05 Crystal Grey Metallic WRX Sport Wagon
Posts: 3,314
Points: 8,662, Level: 62
Points: 8,662, Level: 62 Points: 8,662, Level: 62 Points: 8,662, Level: 62
Level up: 71%, 88 to go!
Level up: 71% Level up: 71% Level up: 71%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Send a message via AIM to MVWRX
^^Whoa, definatly bring that to the dealer.
Offline
 
Reply With Quote
Old 09-06-2005, 11:47 PM   #9
Registered User
Personal Sales Rating: (5)
 
ej20boost's Avatar
 
Join Date: Feb 2004
Location: hawaii
Drives : My 2009 FIT for sale!!!!!!!!!!
Posts: 693
ej20boost
Points: 7,996, Level: 60
Points: 7,996, Level: 60 Points: 7,996, Level: 60 Points: 7,996, Level: 60
Level up: 23%, 154 to go!
Level up: 23% Level up: 23% Level up: 23%
Daily Activity: 0.7%
Daily Activity: 0.7% Daily Activity: 0.7% Daily Activity: 0.7%
Send a message via Skype™ to ej20boost
smell the oil..... does smell like engine oil or trans oil? is most oil by the back of the trans where the driveshaft and trans meet or more to the engine side?

did you change trans fluid recently? it maybe overfilled<just my cents on that. had something like that b4.

Last edited by ej20boost; 09-06-2005 at 11:55 PM.
Offline
 
Reply With Quote
Old 09-07-2005, 02:46 PM   #10
Registered User
Personal Sales Rating: (0)
 
Tomasu's Avatar
 
Join Date: Apr 2005
Location: SoCal
Drives : 05 WRX
Posts: 41
Points: 5,581, Level: 48
Points: 5,581, Level: 48 Points: 5,581, Level: 48 Points: 5,581, Level: 48
Level up: 16%, 169 to go!
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Took it to the dealership, they said it was the seal between the drive shaft and the transmission that was faulty from the factory and its being replaced under warranty...

once i get it back ill keep an eye on it and see if anything else may be wrong.

I smelled the oil but couldnt tell the difference between it and motor oil.
Offline
 
Reply With Quote
Old 09-07-2005, 02:50 PM   #11
Registered User
Personal Sales Rating: (5)
 
ej20boost's Avatar
 
Join Date: Feb 2004
Location: hawaii
Drives : My 2009 FIT for sale!!!!!!!!!!
Posts: 693
ej20boost
Points: 7,996, Level: 60
Points: 7,996, Level: 60 Points: 7,996, Level: 60 Points: 7,996, Level: 60
Level up: 23%, 154 to go!
Level up: 23% Level up: 23% Level up: 23%
Daily Activity: 0.7%
Daily Activity: 0.7% Daily Activity: 0.7% Daily Activity: 0.7%
Send a message via Skype™ to ej20boost
i was kinda thinking it was from somewhere there(transmission output shaft seal) since you took most of the pics by the back of trans(it was kinda hard to figure out thru the pics). well transmission oil has a very distinct smell(it stinks! like a$$) hopefully clean it...... but most likely it is.

Quote:
Originally Posted by Tomasu
Took it to the dealership, they said it was the seal between the drive shaft and the transmission that was faulty from the factory and its being replaced under warranty...

once i get it back ill keep an eye on it and see if anything else may be wrong.

I smelled the oil but couldnt tell the difference between it and motor oil.
Offline
 
Reply With Quote
Old 09-07-2005, 02:50 PM
I-Club
Subaru WRX




Paid Advertisement
 
 
 
Reply

Tags
06, 2007, burning, car, leak, leaks, oil, output, seals, shaft, smell, smells, subaru, wagon, wd40, wrx


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 




All times are GMT -7. The time now is 05:17 AM.


Powered by: vBulletin Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2010, Crawlability, Inc.

-= NOT AUTHORIZED OR APPROVED BY OR AFFILIATED WITH SUBARU OF AMERICA OR FUJI HEAVY INDUSTRIES LTD. =-