Go Back  i-Club > i-Club Forums > Vendor, Tuning, Service, and Parts Review
APS Turbo Inlet supplied with incorrect hose type >

APS Turbo Inlet supplied with incorrect hose type

Notices
Vendor, Tuning, Service, and Parts Review Feel free to discuss vendor experiences but please don't use the forum as your own private soapbox to perpetually bash specific vendors.

APS Turbo Inlet supplied with incorrect hose type

Old 07-05-2010, 04:20 AM
  #1  
Registered User
Thread Starter
 
TurboQueef's Avatar
 
Join Date: Mar 2006
Location: Southwest MI
Posts: 19
Car Info: 2005 STI: [email protected]
Thumbs down APS Turbo Inlet supplied with incorrect hose type

Good day,

I have been running an APSWRX/CID/01 turbo inlet for 22K miles.

I want to make everyone aware of two safety issues I discovered during this my use of the APS product.

1) As soon as I installed the inlet, I noticed raw fuel smell in the engine compartment and sometimes the cabin. I contacted APS and the manufacture of the hose they supplied with the kit and determined the hose was not recommended for use with fuel. I replaced one of the sections of the fuel hose (the one I could get to without removing the top of engine parts). The other piece I just removed during my engine refresh project. (it was cracked, seeping fuel but not leaking yet)

2) As I was re-installing the APS inlet for my refreshed engine build, I noticed two of the crankcase breather hoses were puffed out and distorted looking. I could see oil seeping from them so I investigated... and determine that for a second occurrence, APS supplied a hose not intended for fuel/oil.

I really like the APS products overall but ... someone at APS had their head up their *** when sourcing the components.

Please take care if you use the APS with the hoses they supply.... could lead to a safety issue very easily...

Here is a video I made visualizing the problem:

http://www.youtube.com/watch?v=QJLHO3msRpk
TurboQueef is offline  
Old 07-05-2010, 04:35 AM
  #2  
Registered User
iTrader: (2)
 
SR20steve's Avatar
 
Join Date: Sep 2007
Location: Discovery Bay, CA
Posts: 1,569
Car Info: Evo X GSR, F250 Powerstroke Diesel
Damn I had the same inlet and always had a fuel smell...I wonder if that was the problem?
SR20steve is offline  
Old 07-05-2010, 04:45 AM
  #3  
Registered User
Thread Starter
 
TurboQueef's Avatar
 
Join Date: Mar 2006
Location: Southwest MI
Posts: 19
Car Info: 2005 STI: [email protected]
Originally Posted by SR20steve View Post
Damn I had the same inlet and always had a fuel smell...I wonder if that was the problem?
I would not be surprised... the hose does not leak and ASP engineers say it never will poo gas but.... the smell drove me crazy... I just replaced it with "fuel injector" hose.

Good luck
TurboQueef is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Krang
Hawaii Classifieds
4
03-31-2011 11:06 AM
WrbImprezaSti
NorCal Classifieds
5
12-10-2007 09:29 PM
WrbImprezaSti
New Aftermarket Car Parts For Sale
0
12-08-2007 09:04 AM
View Askew
NorCal Classifieds
3
11-03-2005 09:11 AM


Thread Tools
Search this Thread
Quick Reply: APS Turbo Inlet supplied with incorrect hose type


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.