Notices
Engine Management Cobb AccessPort, EcuTek, TEC, Motec, Link, and others. The ins and outs of high-performance engine tuning.

Sti intake intercooler maf sensor problems

Old 11-03-2013, 08:24 PM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2013
Posts: 10
Sti intake intercooler maf sensor problems

Hey I have a 06 Sti and I just installed the Perrin fmic kit with the red perrin short ram intake using stock bov because I haven't gotten a flange for my greddy rz bov. Okay so I got everything hooked up using the stock maf sensor on the Perrin short ram intake. My intake cone the sponge filter came drenched in oil I read on perrins site that they spray it with oil to keep dirt off. So my first pull from first to second gear I hear a pop and the car shut off it would start and shut right off it would barely move so I plug out the maf sensor and the runs but not fast at all and when I plug the sensor back in while the car is running it shuts off. so I cleaned the sensor that didn't work now I want to know what I should do. Should I wash the cone part of the intake with water does the oil necessarily have to be in there? And should I buy a new stock maf sensor from denso? Or will any cheap eBay maf sensor work?
anthonys192 is offline  
Old 11-03-2013, 09:01 PM
  #2  
Registered User
iTrader: (57)
 
xhengmanx's Avatar
 
Join Date: Aug 2006
Location: the area
Posts: 7,377
Car Info: 04 impreza wrx R.I.P Daniel Wentz JOEBOBBUCKET
get a tune?
xhengmanx is offline  
Old 11-04-2013, 05:34 AM
  #3  
Registered User
Thread Starter
 
Join Date: Nov 2013
Posts: 10
I really think a tune wouldn't help it's def the maf sensor because when I unplug it from the car the car starts right up
anthonys192 is offline  
Old 01-09-2014, 09:46 PM
  #4  
Registered User
 
Join Date: Nov 2013
Location: Fremont ca
Posts: 7
Car Info: 2014 sti
Thats a hot film maf sensor if u clean em u will make things worse u cannot clean hot film maf sensors only replace with denso brand or Hitachi
eTron is offline  
Old 01-09-2014, 11:08 PM
  #5  
Registered User
iTrader: (57)
 
xhengmanx's Avatar
 
Join Date: Aug 2006
Location: the area
Posts: 7,377
Car Info: 04 impreza wrx R.I.P Daniel Wentz JOEBOBBUCKET
Also sure you don't have a boost leak anywhere?
xhengmanx is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
anthonys192
Engine/Power - EJ25T (STI and 2006+ WRX)
3
11-07-2013 12:27 PM
anthonys192
Aftermarket Forced Induction - Turboed factory NA engines
0
11-03-2013 08:24 PM
dan avoN7
NorCal Classifieds
3
12-19-2006 09:46 AM
grex767
Engine/Power - EJ20T (pre-2006 WRX and JDM)
6
05-27-2006 10:37 AM


Thread Tools
Search this Thread
Quick Reply: Sti intake intercooler maf sensor problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.