2007 STi cutting power while spinning in snow? - i-Club

Go Back  i-Club > General Forums > Subaru General
2007 STi cutting power while spinning in snow? >

2007 STi cutting power while spinning in snow?

Notices
Subaru General Anything about Subaru related that would not be more appropriate in another existing i-Club forum.

2007 STi cutting power while spinning in snow?

Old 11-28-2016, 03:06 PM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2016
Location: Manitoba
Posts: 1
Car Info: 2007 Subaru WRX Impreza STi
2007 STi cutting power while spinning in snow?

Good Evening Gents, first off I'd like to say I hope this is being posted in the correct area, I read the posting rules sticky and I shall gladly abide by them all, I'm just posting this in here 'cause I'm not sure where else it should go! Apologies if its in the wrong area.
Now, on to my problemo. We just had our first snowfall of the winter this morning in Manitoba, Canada, and being a Subaru owner, well I decided to obviously take the car out for a little spin. However, I quickly figured out I was having issues. I am able to take off like usual no problem, however, as soon as I throttle it enough to start spinning, I usually lose power immediately after. I'll try my best to explain it...I take off in first, driving slowly on a snowy, empty parking lot, with no one around for miles. I then proceed to throttle it enough to get it to spin, I then let off the throttle to slow myself down somewhat, and immediately try to throttle again to try to keep the drift going, however, the second time I punch the throttle I have no power, once I wait for the RPMs to drop back down to whatever, 1-3k, I can punch it again for a little bit, it spins out, then I'll let off the throttle, and always the second time around in the cycle I have no power! I'm stumped! On the road I can tear thru my gears no problem, I've launched the car, it does fine, sometimes however in the past when I have drifted a corner on dry pave, starting off in first, slowly coming into the corner then gunning it, Ill swing out but at around 5200-6k RPMs It would occasionally just completely cut out instead of going all the way to redline...
Car is a 2007 Subaru STi, with the following Mods, E-tuned.
Blouch Dom 3XTR turbo
DW 850cc Injectors
WB 255 Fuel Pump
Kstech 73mm CAi
3 inch turbo back exhaust
Tial 38mm EWG kit with tube dumping into exhaust
Grimmspeed 3port EBCS
B00sted07 is offline  
Old 11-28-2016, 10:48 PM
  #2  
Registered User
iTrader: (19)
 
CHESTON's Avatar
 
Join Date: Aug 2006
Location: Campbell
Posts: 1,441
Car Info: AW Pig-STI
well, it could be that some of the electronic nannies are kicking in.

are you seeing ANY lights going on in the dashboard?

In particular, is your DCCD light flashing? If not, what about the Rear Diff'l light?
CHESTON is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Wrxplaya11
Engine/Power - EJ20T (pre-2006 WRX and JDM)
5
02-27-2004 09:39 AM
wrxwagon2b
Random Thoughts/Off Topic
10
01-18-2004 10:59 PM
brucelee
Bay Area
17
06-30-2003 08:08 PM
EtchyLives
Hawaii
2
12-14-2002 10:49 PM
onesillyracer
Tri-State
15
11-26-2002 09:43 AM


Thread Tools
Search this Thread
Quick Reply: 2007 STi cutting power while spinning in snow?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.