Stupidchicken's Super Sweet Subaru Saga Thread - Page 22 - i-Club

Go Back  i-Club > General Forums > Show and Shine
Stupidchicken's Super Sweet Subaru Saga Thread >

Stupidchicken's Super Sweet Subaru Saga Thread

Notices
Show and Shine Show off your completed pride and joy here.

Stupidchicken's Super Sweet Subaru Saga Thread

Old 07-07-2011, 12:03 AM
  #316  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
Yup they sure are
stupidchicken03 is offline  
Old 07-07-2011, 01:28 AM
  #317  
Registered User
iTrader: (10)
 
av3rag3's Avatar
 
Join Date: Aug 2009
Location: SJ, CA
Posts: 437
Car Info: 2002 WRX
Did you have any problems with glare to other people? And what temps are they?
av3rag3 is offline  
Old 07-07-2011, 06:34 AM
  #318  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
if i remember right, they are 6k.

I get some ppl flash their high beams at me once in a while.. but thats about it. They're just bright lol. They think im driving around with my high beams on i guess
stupidchicken03 is offline  
Old 07-07-2011, 10:09 AM
  #319  
Registered User
iTrader: (10)
 
av3rag3's Avatar
 
Join Date: Aug 2009
Location: SJ, CA
Posts: 437
Car Info: 2002 WRX
ahh ok. thanks for the info. I plan on getting some for my bugeye. What brand of HIDs did you use?
av3rag3 is offline  
Old 07-07-2011, 10:19 AM
  #320  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
bought them off a vendor from nasioc. Lifetime warranty on balasts AND bulbs.

I got the hi/low BUT the Hi beams dont work I guess on subaru and Fords they have been having that issue.

They offered for me to send them back and they would send me just the "low" single beam ones and a refund for the difference, but i didnt want to have to take everything off and wait to get the others in... so i just kept them.

heres the thread/vendor i bought from
http://forums.nasioc.com/forums/show....php?t=2113240
stupidchicken03 is offline  
Old 08-01-2011, 12:37 PM
  #321  
Registered User
iTrader: (10)
 
av3rag3's Avatar
 
Join Date: Aug 2009
Location: SJ, CA
Posts: 437
Car Info: 2002 WRX
cool.

here's a pic of the control towers on our wrx.

av3rag3 is offline  
Old 08-01-2011, 05:52 PM
  #322  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
yea that looks so good!

Plans changed and ive gotta get the bracket back from the original guy who was gunna make em for me. Ive got a second guy lined up whos gunna do em for me tho
stupidchicken03 is offline  
Old 08-05-2011, 01:18 PM
  #323  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
Did a homemade bracket and hardwired my radar detector today

Name:  Detector.jpg
Views: 2
Size:  53.3 KB
stupidchicken03 is offline  
Old 08-05-2011, 01:20 PM
  #324  
Registered User
iTrader: (23)
 
LOL_VTEC's Avatar
 
Join Date: Apr 2009
Location: Bay Area 925
Posts: 5,432
Car Info: 2018 Tacoma TRD PRO
So what's your plan for BAM? Dirty or clean?
LOL_VTEC is offline  
Old 08-05-2011, 01:32 PM
  #325  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
i want dirty

But i cant think of anywhere right now that has mud besides Folsom Lake and i dont wanna pay $10 to get in just to drive around for 10mins


So ill prolly just roll as is.. still pretty dirty just not muddy haha
stupidchicken03 is offline  
Old 08-11-2011, 01:32 PM
  #327  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
Thanks

I got the idea from Sybir at the lat Thurs night meet. He modified a sun visor clip to make it work like that.

I just has scrap metal around so i used that haha.
Subaru Impreza WRX STI Forums: IWSTI.com - View Single Post - Nor Cal Chat Thread - In Memory of Eric "jagstyle" Houts
stupidchicken03 is offline  
Old 08-21-2011, 12:55 PM
  #328  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
my friend and i decided to tackle the issue with my high beams on the HIDs.

Pulled out the volt meter and plugged away. The harness that came with the kit was basically useless. We spliced and soldered up our own while continuously checking things along the way. Things work great now. Hi/lows and the Hi beam indicator on the dash is only on when the hi beams are

Ill try to get some pics later if im not too lazy lol
stupidchicken03 is offline  
Old 09-09-2011, 12:40 AM
  #329  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
Sooooo some great news tonight driving back home from the local meet..... Idk what made me do it but, i decided to press my fog light button on...........AND THEY WORKED!!!!

They havnt worked since i installed my STi cluster! I thought it had something to do with the cluster but now i think it was due to my HIDs or those and a combination of the cluster.

Im guessing since my friend and i made our own harness for the Hi/low HIDs to work, that sorted out the fog light issue in some weird way

All i know now is that tomorrow i think ill be buying the yellow stain glass paint to get the yellow fogs ive always wanted haha!
stupidchicken03 is offline  
Old 10-14-2011, 02:54 PM
  #330  
Churro Aficionado
Thread Starter
iTrader: (38)
 
stupidchicken03's Avatar
 
Join Date: Feb 2008
Location: IG - @thomas.teammoist
Posts: 54,257
Car Info: IG - @TEAMMOISTOFFICIAL
Last friday i got all new glass on the car (except for the rear window)



And today I got new tint all around

5% on the rear 3
20% on the front 2
45% on the windshield with a 5% sun strip across the top


Name:  2011-10-14_14-29-59_742.jpg
Views: 2
Size:  81.8 KB
stupidchicken03 is offline  

Thread Tools
Search this Thread
Quick Reply: Stupidchicken's Super Sweet Subaru Saga Thread


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.